Theme cannot be saved

Description

The theme cannot be saved – for example, after a Shopware update – so your changes will not be applied.

Cause

The cause is stated in the accompanying error message. Usually, you have configured a configuration field incorrectly.

Potential error messages:

Further causes

Another type of incorrect configuration is an incorrectly written or incorrectly used variable. This usually results in the following error message:

In addition, server performance can also be a problem when saving. This manifests itself in the following error:

Solution

All you need to do is correct the relevant configuration field. The error message may indicate which configuration field is affected.

You can alternatively validate your configuration:

Validate the theme configuration

Why hasn't this error been noticed before?

You may not have noticed this error in Shopware 6.6. However, with Shopware 6.7, the validation of the theme configuration has been significantly improved so that even minor typos are now reliably detected.

Issue not solved?

If you could not solve the problem, simply start the ThemeWare® Debugging. You can open a support ticket in case you are not able to solve the problem yourself:

Last updated

Was this helpful?