# Configuration fields in the "General" tab

## Description

You may find configuration fields (usually titled "twt-...") in the "General" tab of the ThemeWare® configuration that have no effect.

![Orphaned configuration fields automatically end up in the "General" tab."](/files/x12NM2C69u8elwvzCkxB)

## Cause

These are "**orphaned configuration fields**". These occur when a configuration field has been edited by the user at some point and this configuration field is deleted with a theme update.

{% hint style="info" %}
**Note**: With ThemeWare® you benefit from continuous development. From time to time it may happen that configuration fields are removed or replaced with an update.
{% endhint %}

Unfortunately, the Shopware update routine currently does not automatically remove those configuration fields.

## Solution

In response to our issue (NEXT-14571), Shopware has extended the "Save" button in the theme configuration in Shopware 6.4.8.0 and added a "Clean" option. This allows you to delete "orphaned configuration fields".

You can find out how to remove "orphaned configuration fields" in the article [Cleaning up ThemeWare®](/knowledge-base/tutorials/administration/cleaning-up-themeware.md).

#### Issue not solved?

If you could not solve the problem, simply start the ThemeWare® Debugging. You can open a support ticket in case you are not able to solve the problem yourself:

{% embed url="<https://debugging.themeware.design/en>" %}


---

# Agent Instructions: Querying This Documentation

If you need additional information that is not directly available in this page, you can query the documentation dynamically by asking a question.

Perform an HTTP GET request on the current page URL with the `ask` query parameter:

```
GET https://knowledge.themeware.design/knowledge-base/common-issues/administration/configuration-fields-in-the-general-tab.md?ask=<question>
```

The question should be specific, self-contained, and written in natural language.
The response will contain a direct answer to the question and relevant excerpts and sources from the documentation.

Use this mechanism when the answer is not explicitly present in the current page, you need clarification or additional context, or you want to retrieve related documentation sections.
