ThemeWare® cannot be updated
Description
In some rare cases it might happen that an update is available in the extension administration, but it cannot be executed.
Cause
Unfortunately, there is no definite solution so far, as the problem can have various causes.
Solutions
There are currently several possible workarounds:
1) Check the PHP memory limit
In our experience, an insufficient PHP memory_limit is often the cause of problems with updates of extensions (plugins, apps or themes).
Check and if necessary increase the PHP memory_limit to the value recommended by Shopware of "512 MB or higher".
If you do not know how to change the value, your hoster will certainly be happy to help you.
Important: Even if your hosting (especially shared hosting) indicates a sufficient memory limit, it is not automatically guaranteed you will receive that amount. Contact your hoster or agency to have it checked.
2) Deactivate theme
It is always a good idea to deactivate (not uninstall!) an extension (plugin or app) or theme before updating. This often helps with update problems.
Instructions: Deactivating ThemeWare®
Instructions: Updating ThemeWare®
Instructions: Activating ThemeWare®
3) Reinstall theme
In some rare cases, the update with step 1 and 2 still does not work. There might be e.g. a problem with file permissions. In most of such cases the only thing that helps is a reinstallation.
Important: Please save your theme configuration first. Please find the instruction for this in the article Exporting and importing the ThemeWare® configuration.
Instructions: Uninstalling ThemeWare®
Instructions: Updating ThemeWare®
Instructions: Installing ThemeWare®
Solutions (for experienced users)
Update theme manually
In addition to the above options, a manual theme update via the Shopware 6 Extension Management would also be an option.
Attention: As incompatibilities may occur, it is essential to check the Shopware compatibility of ThemeWare®. We therefore only recommend this method to experienced users!
Instructions: Updating ThemeWare® manually
Update theme via FTP
You can also upload the ThemeWare® zip file to your server manually via FTP instead of using the Extension Management. Take particular care that the file permissions of the source files do not get messed up.
Attention: As incompatibilities may occur, it is essential to check the Shopware compatibility of ThemeWare®. We therefore only recommend this method to experienced users!
Screenshots
Issue not solved?
If you could not solve the problem, simply start the ThemeWare® Debugging. You can open a support ticket in case you are not able to solve the problem yourself:
Last updated
Was this helpful?