# ThemeWare® cannot be updated

## Description

In some rare cases it might happen that an update is available in the extension administration, but it cannot be executed.

{% hint style="info" %}
**Note**: This article only refers to the case that an update is listed in the Extension Management, but the update does not work.

In case the update option is missing in the Extension Management, please look at the article [themeware-update-not-available](https://knowledge.themeware.design/knowledge-base/common-issues/administration/themeware-update-not-available "mention").
{% endhint %}

## Cause

Unfortunately, there is no definite solution so far, as the problem can have various causes.

## Solutions

There are currently several possible workarounds:

### 1) Check the PHP memory limit

In our experience, an insufficient **PHP memory\_limit** is often the cause of problems with updates of extensions (plugins, apps or themes).

Check and if necessary increase the PHP memory\_limit to the value recommended by Shopware of "**512 MB or higher**".

If you do not know how to change the value, your hoster will certainly be happy to help you.

{% hint style="warning" %}
**Important**: Even if your hosting (especially shared hosting) indicates a sufficient memory limit, it is not automatically guaranteed you will receive that amount. Contact your hoster or agency to have it checked.
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### 2) Deactivate theme

It is always a good idea to deactivate (not uninstall!) an extension (plugin or app) or theme before updating. This often helps with update problems.

1. Instructions: [deactivating-themeware](https://knowledge.themeware.design/knowledge-base/tutorials/administration/deactivating-themeware "mention")
2. Instructions: [updating-themeware](https://knowledge.themeware.design/knowledge-base/tutorials/administration/updating-themeware "mention")
3. Instructions: [activating-themeware](https://knowledge.themeware.design/knowledge-base/tutorials/administration/activating-themeware "mention")

### 3) Reinstall theme

In some rare cases, the update with step 1 and 2 still does not work. There might be e.g. a problem with file permissions. In most of such cases the only thing that helps is a reinstallation.

{% hint style="info" %}
**Note**: The theme configuration is currently kept even during the uninstall process **unless** you select the option "Remove all app data permanently". *(Stand: Shopware 6.4.11.0)*
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{% hint style="warning" %}
**Important**: Please save your theme configuration first. Please find the instruction for this in the article [exporting-and-importing-the-themeware-configuration](https://knowledge.themeware.design/knowledge-base/profi-knowledge/exporting-and-importing-the-themeware-configuration "mention").
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1. Instructions: [uninstalling-themeware](https://knowledge.themeware.design/knowledge-base/tutorials/administration/uninstalling-themeware "mention")
2. Instructions: [updating-themeware](https://knowledge.themeware.design/knowledge-base/tutorials/administration/updating-themeware "mention")
3. Instructions: [installing-themeware](https://knowledge.themeware.design/knowledge-base/tutorials/administration/installing-themeware "mention")

## Solutions (for experienced users)

### Update theme manually

In addition to the above options, a manual theme update via the Shopware 6 Extension Management would also be an option.

{% hint style="danger" %}
**Attention**: As incompatibilities may occur, it is essential to check the Shopware compatibility of ThemeWare®. We therefore only recommend this method to experienced users!
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* Instructions: [updating-themeware-r-manually](https://knowledge.themeware.design/knowledge-base/profi-knowledge/updating-themeware-r-manually "mention")

### Update theme via FTP

You can also upload the ThemeWare® zip file to your server manually via FTP instead of using the Extension Management. Take particular care that the file permissions of the source files do not get messed up.

{% hint style="danger" %}
**Attention**: As incompatibilities may occur, it is essential to check the Shopware compatibility of ThemeWare®. We therefore only recommend this method to experienced users!
{% endhint %}

#### Screenshots

![ThemeWare® maunell updaten](https://1979975522-files.gitbook.io/~/files/v0/b/gitbook-x-prod.appspot.com/o/spaces%2F178YilsPBIFHBAxTvcMo%2Fuploads%2Fgit-blob-8151a4cf38dbde38d5a09822c418a93edae8abb3%2Fplugin--twt-manual-update.png?alt=media)

#### Issue not solved?

If you could not solve the problem, simply start the ThemeWare® Debugging. You can open a support ticket in case you are not able to solve the problem yourself:

{% embed url="<https://debugging.themeware.design/en>" %}
