# CMS blocks are not displayed in Shopping Experience

## Description

The Shopping Experience layout has been assigned but the CMS blocks are not displayed in the storefront.

#### Basic information

ThemeWare® provides "CMS animations". With this feature, CMS blocks are hidden and displayed with a CSS animation when the CMS page is scrolled as soon as the corresponding CMS block comes into the viewable area of the browser window.

This animation is managed by JavaScript.

## Cause

If the CMS blocks are not displayed as intended, there is a 99.9% chance that you will find one or more error messages in the browser DevTools that refer to JavaScript errors.

![](/files/0u1JKGKhbbesv8RASFAk)

JavaScript errors caused by third-party extensions can affect ThemeWare® JavaScript features. In this case the scroll animation is obviously affected.

## Solutions

1. Fix the JavaScript error. It often helps to update all extensions.
   * If you want to know which extension is causing the error, deactivate (do not uninstall!) all extensions used once. If the problem no longer exists after deactivating all extensions, the problem is most likely due to one extension.
   * Now activate your extensions one after the other and check after each activated extension whether the error occurs again.
   * You can find more information in the article: [Examining extensions or plugins](/knowledge-base/tutorials/solving-errors/examining-extensions-or-plugins.md)
2. Deactivate the CMS animations
   * Tab "Shopping Experiences" => Block "All types (Shop pages, Landing pages, Listing pages, Product pages)" => Section "CSS scroll animations" => CSS scroll animation (CMS blocks)
   * Tab "Shopping Experiences" => Block "All types (Shop pages, Landing pages, Listing pages, Product pages)" => Section "CSS scroll animations" => CSS scroll animation (Headlines in CMS blocks)


---

# Agent Instructions: Querying This Documentation

If you need additional information that is not directly available in this page, you can query the documentation dynamically by asking a question.

Perform an HTTP GET request on the current page URL with the `ask` query parameter:

```
GET https://knowledge.themeware.design/knowledge-base/common-issues/storefront/cms-blocks-are-not-displayed-in-shopping-experience.md?ask=<question>
```

The question should be specific, self-contained, and written in natural language.
The response will contain a direct answer to the question and relevant excerpts and sources from the documentation.

Use this mechanism when the answer is not explicitly present in the current page, you need clarification or additional context, or you want to retrieve related documentation sections.
