# Allowed memory size of ... bytes exhausted

## Description

If you find the message "**Allowed memory size of ... bytes exhausted**" in the PHP error log or in the Shopware log files, the issue is caused by the **PHP memory\_limit**.

## Cause

The error message "Allowed memory size exhausted" is one of the most common issues in shop or content management systems, especially if you are using a shared hosting service.

This means that the web server limits the amount of memory used by Shopware and the memory provided is not sufficient.

## Solution

The decisive factor in this error is the **PHP memory\_limit** of your web server.

Shopware recommends a memory\_limit of "**512 MB or higher**". Please increase the memory\_limit of your web server to the value recommended by Shopware (or higher).

In case you do not know how to change the value, your hoster will certainly be happy to help you.

{% hint style="warning" %}
**Important**: Even if your hosting (especially shared hosting) indicates a sufficient memory limit, it is not automatically for sure that you will receive that amount. Contact your hoster or agency to have it checked.
{% endhint %}

#### Issue not solved?

If you could not solve the problem, simply start the ThemeWare® Debugging. You can open a support ticket in case you are not able to solve the problem yourself:

{% embed url="<https://debugging.themeware.design/en>" %}


---

# Agent Instructions: Querying This Documentation

If you need additional information that is not directly available in this page, you can query the documentation dynamically by asking a question.

Perform an HTTP GET request on the current page URL with the `ask` query parameter:

```
GET https://knowledge.themeware.design/knowledge-base/common-issues/administration/allowed-memory-size-exhausted.md?ask=<question>
```

The question should be specific, self-contained, and written in natural language.
The response will contain a direct answer to the question and relevant excerpts and sources from the documentation.

Use this mechanism when the answer is not explicitly present in the current page, you need clarification or additional context, or you want to retrieve related documentation sections.
