# Unfortunately something went wrong on the product page

## Description

The error "**Unfortunately, something went wrong.**" appears on the product page if you use our "ThemeWare® Customizing Plugin".

## Cause

In this case, the cause is an outdated version of the extension or an outdated customisation.

## Solution

1. Please remove the content in the following files:
   1. File "**main.scss**":
      * Delete everything
      * File location: `custom/plugins/TcinnCustomizing/src/Resources/app/storefront/src/scss/`
   2. File "**headline.html.twig**":
      * Delete everything from line 2
      * File location: `custom/plugins/TcinnCustomizing/src/Resources/views/storefront/page/product-detail/`
2. Then refresh the storefront once to transfer the changes to the storefront: [Refreshing the storefront](/knowledge-base/tutorials/miscellaneous/refreshing-the-storefront.md)

#### Issue not solved?

If you could not solve the problem, simply start the ThemeWare® Debugging. You can open a support ticket in case you are not able to solve the problem yourself:

{% embed url="<https://debugging.themeware.design/en>" %}


---

# Agent Instructions: Querying This Documentation

If you need additional information that is not directly available in this page, you can query the documentation dynamically by asking a question.

Perform an HTTP GET request on the current page URL with the `ask` query parameter:

```
GET https://knowledge.themeware.design/knowledge-base/common-issues/storefront/unfortunately-something-went-wrong-on-the-product-page.md?ask=<question>
```

The question should be specific, self-contained, and written in natural language.
The response will contain a direct answer to the question and relevant excerpts and sources from the documentation.

Use this mechanism when the answer is not explicitly present in the current page, you need clarification or additional context, or you want to retrieve related documentation sections.
