Configuration fields are missing

Description

One or more configuration fields are missing in the theme configuration although they are listed in the ThemeWare® Config Finder or the ThemeWare® Documentation.

Note: This issue relates to the original theme and not to duplicates. For missing configuration fields in ThemeWare® duplicates, please refer to the article New configuration fields are missing in a theme duplicate after update.

Cause

If one or more configuration fields are missing in the theme configuration, there are two possible causes:

  1. Most likely you are not using the latest version of ThemeWare®.

  2. There was a problem with a Shopware or ThemeWare® update.

Solution

1) Update ThemeWare®

Both the ThemeWare® Documentation and the ThemeWare® Config Finder are based on the latest version of ThemeWare®. If you find a feature or configuration there that is missing in your shop, you are probably not using the latest version of ThemeWare®.

Check whether you are using the latest version of ThemeWare® and update your theme if necessary.

Tip: You can see which version is the latest in the ThemeWare® Changelog, for example.

Note: If you are unable to update ThemeWare®, please take a look at the following article: ThemeWare® update not available.

2) Resolve update errors

Configuration fields are managed by the Shopware Core. ThemeWare® has no feature that adds or removes fields, so unfortunately we have no influence on this.

It may be that an old version of the administration was cached. Please reload the administration with the following key combination:

  • Windows: CTRL + F5

  • Mac: Command + Shift + R

Other solutions

If this does not help, the issue is a bit bigger. Please perform a "Soft Reset" of ThemeWare® using the following instructions:

Performing a ThemeWare® Soft Reset

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